Stop Supporting IE 5, Start Supporting Safari!

December 14th, 2005 | by Mike |

Long story, but I’m moving this weekend and I needed to change auto insurance companies, because my current one thought I was moving to the ghetto or something, and made my new rates ridiculous. Anyway, I ended up with Progressive and I had to sign some electronic documents on their site. I click on the link, sign in and then I get presented with some serious OS-racism: “Compatibility Error: Please click here to download Internet Explorer 5.0” Ouch…and no. There is no way I’m letting that most horrible of horrible browsers on my beautiful iMac. Hell I don’t think you can even download it from Microsoft’s website still can you?

Either way, that was my situation. So I reach for my trusty Safari Debug menu and change the user agent to “IE 6 Windows” and reload. No dice. I tried using Firefox…also denied. Luckily I have Virtual PC installed on my machine which I’m now having to use for this stupid task. I don’t know about anyone else, but I find this very unacceptable.

OS-racism must end. Take the extra time to make a site that works in ALL MODERN BROWSERS. That means: Safari, Firefox, Opera (Yes, Opera), Camino, Internet Explorer 6 (Yes, IE). It does not mean: IE 5.0 for mac. If Microsoft doesn’t support it, no one else should. In fact, that should be the rule: If a browser is no longer updated, web developers (like myself) no longer need to support it. It might be nice if they did for a while, but they don’t have to.

Let it be spoken, let it be done!

You must be logged in to post a comment.